Практическая работа № 11
Дисциплина: Моделирование физических процессов в приложениях
Тема: Создание мини-игры с физикой ткани и верёвки «Ядро на привязи»
Среда разработки: Unity
Формат работы: индивидуальная практическая работа

Цель работы
Создать мини-игру, в которой игрок связан верёвкой с шаром, может выполнять заряжаемый пинок, забрасывать шар в зону зацепа, проходить участок с пропастью и взаимодействовать с тканевой преградой.

Что должно получиться в конце
1 Сцена со стартовой платформой, пропастью, дальней платформой и финишем
2 Игрок с управлением на клавишах WASD и прыжком на Space
3 Шар с физикой
4 Верёвка между игроком и шаром
5 Заряжаемый пинок шара на клавишу E
6 Зона зацепа, в которой шар фиксируется
7 Тканевая преграда или её упрощённая имитация
8 Финишная зона с сообщением о победе

Структура проекта
В проекте будут использоваться такие объекты
1 Ground
2 StartPlatform
3 FarPlatform
4 Player
5 CameraTarget
6 GroundCheck
7 EnergyBall
8 Beam
9 HookZone
10 ClothCurtain или CurtainBlock
11 FinishZone
12 Canvas
13 WinText

Часть 1 Создание проекта и первичная настройка
Шаг 1 Создание проекта
1 Откройте Unity Hub
2 Нажмите New Project
3 Выберите шаблон 3D или 3D Core
4 Введите имя проекта PhysicsGame11
5 Нажмите Create Project
6 После открытия проекта выберите File → Save As
7 Назовите сцену MainScene

Шаг 2 Включение старого типа управления
1 В верхнем меню откройте Edit → Project Settings
2 Слева выберите раздел Player
3 Справа откройте блок Other Settings
4 Найдите раздел Configuration
5 Найдите параметр Active Input Handling
6 Установите значение Input Manager (Old) или Both
7 Если Unity предложит перезапуск редактора, согласитесь
8 После перезапуска снова откройте проект

Шаг 3 Включение настроек для сохранения проекта
1 В верхнем меню откройте Edit → Project Settings
2 Найдите раздел Version Control
3 В поле Mode установите Visible Meta Files
4 Затем откройте раздел Editor
5 Найдите блок Asset Serialization
6 В поле Mode установите Force Text
7 Закройте окно настроек
8 Выполните File → Save
9 Ещё раз сохраните сцену File → Save As и проверьте, что она называется MainScene

Часть 2 Создание сцены
Шаг 4 Создание земли
1 Выберите GameObject → 3D Object → Plane
2 В окне Hierarchy переименуйте объект в Ground
3 В Inspector установите:
1 Position X = 0
2 Position Y = 0
3 Position Z = 0
4 Установите:
1 Scale X = 4
2 Scale Y = 1
3 Scale Z = 6

Шаг 5 Создание стартовой платформы
1 Выберите GameObject → 3D Object → Cube
2 Назовите объект StartPlatform
3 Установите:
1 Position X = 0
2 Position Y = 1
3 Position Z = -8
4 Установите:
1 Scale X = 6
2 Scale Y = 1
3 Scale Z = 6

Шаг 6 Создание дальней платформы
1 Выберите GameObject → 3D Object → Cube
2 Назовите объект FarPlatform
3 Установите:
1 Position X = 0
2 Position Y = 1
3 Position Z = 8
4 Установите:
1 Scale X = 6
2 Scale Y = 1
3 Scale Z = 6
Между StartPlatform и FarPlatform должен остаться промежуток. Это будет пропасть.

Часть 3 Создание игрока
Шаг 7 Создание объекта Player
1 Выберите GameObject → 3D Object → Capsule
2 Назовите объект Player
3 Установите:
1 Position X = 0
2 Position Y = 2
3 Position Z = -8

Шаг 8 Добавление Rigidbody игроку
1 Выберите объект Player
2 Нажмите Add Component
3 Добавьте компонент Rigidbody
4 В настройках Rigidbody установите:
1 Mass = 1
2 Drag = 0
3 Angular Drag = 0.05
4 Use Gravity = включено
5 Freeze Rotation X = включено
6 Freeze Rotation Z = включено

Шаг 9 Создание точки проверки земли
1 Выделите объект Player
2 Выберите GameObject → Create Empty
3 Назовите объект GroundCheck
4 Убедитесь, что он стал дочерним объектом Player
5 Установите:
1 Position X = 0
2 Position Y = -0.9
3 Position Z = 0

Шаг 10 Создание точки камеры
1 Выделите объект Player
2 Выберите GameObject → Create Empty
3 Назовите объект CameraTarget
4 Убедитесь, что он стал дочерним объектом Player
5 Установите:
1 Position X = 0
2 Position Y = 1.5
3 Position Z = -4

Шаг 11 Привязка камеры к игроку
1 В Hierarchy выберите Main Camera
2 Перетащите Main Camera внутрь объекта Player
3 Установите для камеры:
1 Position X = 0
2 Position Y = 3
3 Position Z = -6
4 Установите Rotation:
1 X = 15
2 Y = 0
3 Z = 0

Часть 4 Создание шара
Шаг 12 Создание объекта EnergyBall
1 Выберите GameObject → 3D Object → Sphere
2 Назовите объект EnergyBall
3 Установите:
1 Position X = 1.5
2 Position Y = 1.5
3 Position Z = -8
4 Установите Scale:
1 X = 1.2
2 Y = 1.2
3 Z = 1.2

Шаг 13 Добавление Rigidbody шару
1 Выберите объект EnergyBall
2 Нажмите Add Component
3 Добавьте Rigidbody
4 Установите:
1 Mass = 2
2 Drag = 0.1
3 Angular Drag = 0.05
4 Use Gravity = включено

Часть 5 Создание верёвки
Шаг 14 Добавление визуальной верёвки
1 Выберите объект Player
2 Нажмите Add Component
3 Добавьте Line Renderer
4 Установите:
1 Position Count = 2
2 Start Width = 0.08
3 End Width = 0.08
5 Для поля Material можно оставить стандартный материал или назначить любой простой материал

Шаг 15 Добавление физической связи между игроком и шаром
1 Выберите объект Player
2 Нажмите Add Component
3 Добавьте Spring Joint
4 В поле Connected Body перетащите Rigidbody объекта EnergyBall
5 Установите:
1 Auto Configure Connected Anchor = включено
2 Spring = 25
3 Damper = 4
4 Min Distance = 0
5 Max Distance = 4
6 Tolerance = 0.1

Часть 6 Подготовка слоёв
Шаг 16 Создание слоя Ground
1 Выберите объект Ground
2 В верхней части Inspector найдите поле Layer
3 Нажмите на него и выберите Add Layer
4 Создайте новый слой Ground
5 Вернитесь к объектам Ground, StartPlatform, FarPlatform
6 Назначьте им слой Ground

Часть 7 Создание скриптов
Шаг 17 Создание папки Scripts
1 В окне Project откройте папку Assets
2 Нажмите правой кнопкой мыши
3 Выберите Create → Folder
4 Назовите папку Scripts

Шаг 18 Скрипт движения игрока
1 Откройте папку Scripts
2 Нажмите правой кнопкой мыши
3 Выберите Create → C# Script
4 Назовите скрипт PlayerController
5 Откройте его
6 Полностью удалите старый код
7 Вставьте этот код:
using UnityEngine;

public class PlayerController : MonoBehaviour
{
    public float moveSpeed = 6f;
    public float jumpForce = 7f;
    public Rigidbody rb;
    public Transform groundCheck;
    public float groundCheckRadius = 0.25f;
    public LayerMask groundMask;

    private bool isGrounded;
    private float moveX;
    private float moveZ;

    private void Update()
    {
        moveX = Input.GetAxis("Horizontal");
        moveZ = Input.GetAxis("Vertical");

        isGrounded = Physics.CheckSphere(groundCheck.position, groundCheckRadius, groundMask);

        if (Input.GetKeyDown(KeyCode.Space) && isGrounded)
        {
            rb.AddForce(Vector3.up * jumpForce, ForceMode.Impulse);
        }
    }

    private void FixedUpdate()
    {
        Vector3 move = new Vector3(moveX, 0f, moveZ);
        Vector3 velocity = move * moveSpeed;
        Vector3 currentVelocity = rb.linearVelocity;

        rb.linearVelocity = new Vector3(velocity.x, currentVelocity.y, velocity.z);
    }
}
8 Сохраните файл
9 Вернитесь в Unity
10 Перетащите скрипт PlayerController на объект Player
11 В поле Rb перетащите Rigidbody игрока
12 В поле Ground Check перетащите объект GroundCheck
13 В поле Ground Mask выберите слой Ground

Шаг 19 Скрипт отрисовки верёвки
1 В папке Scripts создайте новый C# Script
2 Назовите его RopeRenderer
3 Откройте файл
4 Полностью замените код на этот:
using UnityEngine;

[RequireComponent(typeof(LineRenderer))]
public class RopeRenderer : MonoBehaviour
{
    public Transform playerPoint;
    public Transform ballPoint;

    private LineRenderer line;

    private void Start()
    {
        line = GetComponent<LineRenderer>();
    }

    private void Update()
    {
        if (playerPoint != null && ballPoint != null)
        {
            line.SetPosition(0, playerPoint.position);
            line.SetPosition(1, ballPoint.position);
        }
    }
}
5 Сохраните файл
6 Вернитесь в Unity
7 Перетащите скрипт RopeRenderer на объект Player
8 В поле Player Point перетащите объект Player
9 В поле Ball Point перетащите объект EnergyBall

Шаг 20 Скрипт заряжаемого пинка шара
1 В папке Scripts создайте новый C# Script
2 Назовите его BallKick
3 Откройте файл
4 Полностью замените код на этот:
using UnityEngine;

public class BallKick : MonoBehaviour
{
    public Rigidbody ballRb;

    public float kickDistance = 2.2f;
    public float minKickForce = 6f;
    public float maxKickForce = 20f;
    public float chargeSpeed = 10f;

    private float currentKickForce;
    private bool isCharging;

    private void Update()
    {
        float distance = Vector3.Distance(transform.position, ballRb.position);

        if (distance <= kickDistance)
        {
            if (Input.GetKeyDown(KeyCode.E))
            {
                isCharging = true;
                currentKickForce = minKickForce;
            }

            if (Input.GetKey(KeyCode.E) && isCharging)
            {
                currentKickForce += chargeSpeed * Time.deltaTime;
                currentKickForce = Mathf.Clamp(currentKickForce, minKickForce, maxKickForce);
            }

            if (Input.GetKeyUp(KeyCode.E) && isCharging)
            {
                Vector3 direction = (ballRb.position - transform.position).normalized;
                direction.y = 0.25f;

                ballRb.AddForce(direction.normalized * currentKickForce, ForceMode.Impulse);

                isCharging = false;
                currentKickForce = 0f;
            }
        }
        else
        {
            isCharging = false;
            currentKickForce = 0f;
        }
    }
}
5 Сохраните файл
6 Вернитесь в Unity
7 Перетащите скрипт BallKick на объект Player
8 В поле Ball Rb перетащите Rigidbody объекта EnergyBall
9 Установите:
1 Kick Distance = 2.2
2 Min Kick Force = 6
3 Max Kick Force = 20
4 Charge Speed = 10

Часть 8 Создание балки и зоны зацепа
Шаг 21 Создание балки
1 Выберите GameObject → 3D Object → Cube
2 Назовите объект Beam
3 Установите:
1 Position X = 0
2 Position Y = 5
3 Position Z = 2
4 Установите Scale:
1 X = 6
2 Y = 0.5
3 Z = 0.5

Шаг 22 Создание HookZone
1 Выберите GameObject → 3D Object → Cube
2 Назовите объект HookZone
3 Установите:
1 Position X = 0
2 Position Y = 4.5
3 Position Z = 2
4 Установите Scale:
1 X = 5
2 Y = 1
3 Z = 1
5 В компоненте Mesh Renderer снимите галочку
6 В компоненте Box Collider включите Is Trigger

Шаг 23 Создание тега Ball
1 Выберите объект EnergyBall
2 В верхней части Inspector откройте поле Tag
3 Нажмите Add Tag
4 Создайте новый тег Ball
5 Вернитесь к объекту EnergyBall
6 Установите ему тег Ball

Шаг 24 Скрипт фиксации шара
1 В папке Scripts создайте новый C# Script
2 Назовите его HookZoneScript
3 Откройте файл
4 Полностью замените код на этот:
using UnityEngine;

public class HookZoneScript : MonoBehaviour
{
    private void OnTriggerEnter(Collider other)
    {
        if (other.CompareTag("Ball"))
        {
            Rigidbody rb = other.GetComponent<Rigidbody>();
            if (rb != null)
            {
                rb.linearVelocity = Vector3.zero;
                rb.angularVelocity = Vector3.zero;
                rb.isKinematic = true;
            }
        }
    }
}
5 Сохраните файл
6 Вернитесь в Unity
7 Перетащите скрипт HookZoneScript на объект HookZone

Часть 9 Создание тканевой преграды
Шаг 25 Упрощённый вариант тканевой преграды
Если не используется полноценный Cloth, выполните этот вариант.
1 Выберите GameObject → 3D Object → Cube
2 Назовите объект CurtainBlock
3 Установите:
1 Position X = 0
2 Position Y = 2
3 Position Z = 11
4 Установите Scale:
1 X = 4
2 Y = 4
3 Z = 0.3
5 При желании создайте материал с тканевым цветом и назначьте его объекту CurtainBlock

Шаг 26 Вариант с Cloth
Если преподаватель дал готовую сетку ткани, можно вместо CurtainBlock использовать реальный Cloth.
1 Добавьте объект ткани в сцену
2 Назовите его ClothCurtain
3 Установите:
1 Position X = 0
2 Position Y = 3
3 Position Z = 11
4 Поставьте рядом две опоры
5 Добавьте компонент Cloth
6 Настройте средние значения жёсткости и затухания
7 Закрепите верхнюю часть ткани
Если Cloth не используется, оставьте CurtainBlock.

Часть 10 Создание финиша
Шаг 27 Создание FinishZone
1 Выберите GameObject → 3D Object → Cube
2 Назовите объект FinishZone
3 Установите:
1 Position X = 0
2 Position Y = 1.2
3 Position Z = 15
4 Установите Scale:
1 X = 4
2 Y = 1
3 Z = 2
5 Отключите Mesh Renderer
6 Включите в Box Collider параметр Is Trigger

Шаг 28 Создание тега Player
1 Выберите объект Player
2 Откройте поле Tag
3 Нажмите Add Tag
4 Создайте тег Player
5 Вернитесь к объекту Player
6 Назначьте ему тег Player

Часть 11 Создание интерфейса
Шаг 29 Создание Canvas
1 Выберите GameObject → UI → Canvas
2 Если Unity предложит создать EventSystem, согласитесь

Шаг 30 Создание текста победы
1 Выделите объект Canvas
2 Выберите Create → UI → Text - TextMeshPro
3 Если Unity предложит импортировать TMP Essentials, согласитесь
4 Назовите объект WinText
5 В поле текста напишите Уровень пройден
6 Увеличьте размер шрифта
7 Разместите текст по центру экрана
8 Снимите галочку с объекта WinText, чтобы он был скрыт до победы

Шаг 31 Скрипт победы
1 В папке Scripts создайте новый C# Script
2 Назовите его FinishTrigger
3 Откройте файл
4 Полностью замените код на этот:
using UnityEngine;

public class FinishTrigger : MonoBehaviour
{
    public GameObject winText;

    private void OnTriggerEnter(Collider other)
    {
        if (other.CompareTag("Player"))
        {
            winText.SetActive(true);
        }
    }
}
5 Сохраните файл
6 Вернитесь в Unity
7 Перетащите скрипт FinishTrigger на объект FinishZone
8 В поле Win Text перетащите объект WinText

Часть 12 Проверка сцены
Шаг 32 Проверка перед запуском
Проверьте по порядку:
1 У Player есть Rigidbody
2 У EnergyBall есть Rigidbody
3 У Player есть Line Renderer
4 У Player есть Spring Joint
5 В Spring Joint в поле Connected Body указан EnergyBall
6 У Player есть скрипты PlayerController, RopeRenderer, BallKick
7 У HookZone есть HookZoneScript
8 У FinishZone есть FinishTrigger
9 У HookZone включён Is Trigger
10 У FinishZone включён Is Trigger
11 У объекта GroundCheck назначен Ground Check в PlayerController
12 У Ground, StartPlatform и FarPlatform назначен слой Ground
13 У Player тег Player
14 У EnergyBall тег Ball
15 У WinText снята галочка активности

Шаг 33 Запуск сцены
1 Нажмите Play
2 Проверьте, что игрок стоит на стартовой платформе
3 Нажмите W A S D и проверьте движение
4 Нажмите Space и проверьте прыжок
5 Подойдите к шару
6 Удерживайте E и отпустите
7 Проверьте, что шар получает слабый удар при коротком удержании и сильный при долгом
8 Попробуйте забросить шар в HookZone
9 Проверьте, что после попадания в HookZone шар фиксируется
10 Пройдите к дальней платформе
11 Пройдите через CurtainBlock или ClothCurtain
12 Дойдите до FinishZone
13 Проверьте, что появляется надпись Уровень пройден

Часть 13 Что сохранить после выполнения работы
Шаг 34 Сохранение проекта
1 Нажмите File → Save
2 Нажмите File → Save As и убедитесь, что сцена называется MainScene
3 Закройте Unity только после сохранения
4 Для сдачи работы сохраните весь проект
5 Обязательно должны сохраниться папки Assets и ProjectSettings

Контрольные вопросы
1 Для чего в этой работе используется Spring Joint
2 Для чего нужен Line Renderer
3 Как работает заряжаемый пинок шара
4 Зачем в проекте включается старый тип управления
5 Зачем включаются Visible Meta Files и Force Text
6 Для чего нужна HookZone
7 Как используется тканевая преграда в этой сцене
8 Почему шару нужен Rigidbody
9 Для чего объектам пола назначается слой Ground
10 Как срабатывает победа в конце уровня

Критерии оценивания
Оценка 5
1 Все объекты сцены созданы
2 Игрок двигается и прыгает
3 Шар связан с игроком
4 Верёвка отображается
5 Заряжаемый пинок работает
6 Шар фиксируется в HookZone
7 Тканевая преграда добавлена
8 Финиш работает
9 Студент может объяснить назначение основных компонентов
Оценка 4
1 Основная сцена работает
2 Есть мелкие ошибки в настройке
3 Часть механик выполнена упрощённо
Оценка 3
1 Выполнена только часть сцены
2 Работают не все механики
3 Студент затрудняется объяснить логику работы
Оценка 2
[bookmark: _GoBack]1 Работа не собрана
2 Основные механики отсутствуют
3 Проект не запускается корректно
