Практическая работа 12
Тема
Создание игры «Парусник в бесконечном мире» с использованием моделирования физических эффектов
Цель работы
Создать в Unity игровой прототип, в котором объединяются физика ткани, физика верёвки, система частиц, симуляция воды, воздуха и газа, а также процедурная генерация бесконечного мира
Результат работы
В конце практической работы у вас должен получиться проект, в котором
1 лодка движется по воде
2 парус влияет на скорость движения
3 верёвки удерживают парус
4 частицы показывают воду, ветер и туман
5 в мире есть зоны усиленного ветра
6 создаётся бесконечный мир из водных сегментов
7 на пути появляются препятствия
8 на экране отображается пройденная дистанция и сила ветра
Программное обеспечение
1 Unity Hub
2 Unity 3D
3 шаблон Universal 3D
4 Visual Studio
5 Git или Plastic SCM
1 Создание проекта
Шаг 1 Создание нового проекта
1 Откройте Unity Hub
2 Нажмите New project
3 Выберите шаблон Universal 3D
4 Назовите проект SailInfiniteWorld
5 Укажите папку для сохранения
6 Нажмите Create project
Шаг 2 Включение контроля версий
1 Сразу после открытия проекта включите систему контроля версий
2 Если используется Plastic SCM откройте Window → Plastic SCM
3 Инициализируйте репозиторий
4 Сделайте первый коммит с комментарием Initial project setup
5 Если используется Git инициализируйте репозиторий в папке проекта
6 Сделайте первый коммит
2 Подготовка структуры проекта
Шаг 3 Создание папок
1 В окне Project откройте папку Assets
2 Создайте папки
3 Scenes
4 Scripts
5 Prefabs
6 Materials
7 Audio
8 UI
Шаг 4 Создание сцены
1 Откройте папку Scenes
2 Создайте новую сцену
3 Назовите её OceanScene
4 Сохраните сцену
3 Создание воды и начального окружения
Шаг 5 Создание первого сегмента воды
1 В Hierarchy нажмите правой кнопкой мыши
2 Выберите 3D Object → Plane
3 Назовите объект WaterTile_00
4 Установите Position
5 X = 0
6 Y = 0
7 Z = 0
8 Установите Scale
9 X = 5
10 Y = 1
11 Z = 5
Шаг 6 Создание материалов воды
1 Откройте папку Materials
2 Создайте 4 материала
3 M_Water_Calm
4 M_Water_Deep
5 M_Water_Storm
6 M_Water_Shallow
Шаг 7 Настройка материалов воды
1 Для M_Water_Calm задайте светло-синий цвет и Smoothness около 0.7
2 Для M_Water_Deep задайте тёмно-синий цвет и Smoothness около 0.8
3 Для M_Water_Storm задайте серо-синий цвет и Smoothness около 0.5
4 Для M_Water_Shallow задайте голубовато-зелёный цвет и Smoothness около 0.6
Шаг 8 Назначение стартового материала воде
1 Перетащите материал M_Water_Calm на WaterTile_00
Шаг 9 Подготовка освещения
1 Переименуйте Directional Light в Sun
2 Поверните свет так, чтобы сцена освещалась сверху и немного сбоку
4 Создание парусника
Шаг 10 Создание корпуса лодки
1 В Hierarchy создайте 3D Object → Cube
2 Назовите объект Boat
3 Установите Scale
4 X = 1.5
5 Y = 0.5
6 Z = 3
7 Установите Position
8 X = 0
9 Y = 0.5
10 Z = 0
11 Добавьте компонент Rigidbody
12 В Rigidbody задайте
13 Mass = 10
14 Drag = 1
15 Angular Drag = 2
16 Use Gravity включено
Шаг 11 Создание носовой части
1 Внутри Boat создайте 3D Object → Cube
2 Назовите объект BoatFront
3 Уменьшите его размер
4 Сместите немного вперёд по оси Z
5 Этот объект нужен для визуального обозначения направления лодки
Шаг 12 Создание мачты
1 Внутри Boat создайте 3D Object → Cylinder
2 Назовите объект Mast
3 Установите Scale
4 X = 0.1
5 Y = 1.5
6 Z = 0.1
7 Установите Position
8 X = 0
9 Y = 1.5
10 Z = 0
Шаг 13 Создание точки вращения паруса
1 Внутри Boat создайте Empty Object
2 Назовите объект SailPivot
3 Установите Position
4 X = 0
5 Y = 1.5
6 Z = 0
Шаг 14 Создание паруса
1 Внутри SailPivot создайте 3D Object → Plane
2 Назовите объект Sail
3 Установите Rotation
4 X = 90
5 Y = 0
6 Z = 0
7 Установите Scale
8 X = 0.4
9 Y = 1
10 Z = 0.8
11 При необходимости поднимите и сместите объект так, чтобы он располагался рядом с мачтой
5 Создание визуального эффекта ткани
Шаг 15 Создание скрипта SailClothEffect.cs
Создайте в папке Scripts скрипт SailClothEffect.cs и вставьте код
using UnityEngine;

public class SailClothEffect : MonoBehaviour
{
    public float waveSpeed = 2f;
    public float waveAmount = 5f;
    public Transform sailVisual;

    void Update()
    {
        if (sailVisual == null) return;

        float angle = Mathf.Sin(Time.time * waveSpeed) * waveAmount;
        sailVisual.localRotation = Quaternion.Euler(90f, angle, 0f);
    }
}
Шаг 16 Подключение скрипта ткани
1 Выделите объект SailPivot
2 Добавьте компонент SailClothEffect
3 В поле Sail Visual перетащите объект Sail
6 Управление лодкой и парусом
Шаг 17 Создание скрипта BoatController.cs
Создайте в папке Scripts скрипт BoatController.cs и вставьте код
using UnityEngine;

public class BoatController : MonoBehaviour
{
    public Rigidbody rb;
    public Transform sailPivot;

    public float moveForce = 20f;
    public float turnSpeed = 50f;
    public float sailTurnSpeed = 40f;

    [Range(-90f, 90f)]
    public float sailAngle = 0f;

    public Vector3 windDirection = new Vector3(1f, 0f, 1f);
    public float windStrength = 1f;

    private float currentWindBoost = 1f;
    private float waterResistanceMultiplier = 1f;

    void Start()
    {
        if (rb == null)
            rb = GetComponent<Rigidbody>();

        windDirection.Normalize();
    }

    void Update()
    {
        float turnInput = Input.GetAxis("Horizontal");
        transform.Rotate(Vector3.up * turnInput * turnSpeed * Time.deltaTime);

        float sailInput = 0f;

        if (Input.GetKey(KeyCode.Q))
            sailInput = -1f;
        if (Input.GetKey(KeyCode.E))
            sailInput = 1f;

        sailAngle += sailInput * sailTurnSpeed * Time.deltaTime;
        sailAngle = Mathf.Clamp(sailAngle, -90f, 90f);

        if (sailPivot != null)
            sailPivot.localRotation = Quaternion.Euler(0f, sailAngle, 0f);
    }

    void FixedUpdate()
    {
        Vector3 sailForward = sailPivot.forward;
        float efficiency = Vector3.Dot(sailForward.normalized, windDirection.normalized);
        efficiency = Mathf.Abs(efficiency);

        float finalForce = moveForce * efficiency * windStrength * currentWindBoost * waterResistanceMultiplier;
        rb.AddForce(transform.forward * finalForce);
    }

    public void SetWindBoost(float value)
    {
        currentWindBoost = value;
    }

    public void SetWaterResistance(float value)
    {
        waterResistanceMultiplier = value;
    }
}
Шаг 18 Подключение скрипта управления
1 Выделите объект Boat
2 Добавьте компонент BoatController
3 В поле Rb перетащите Rigidbody лодки
4 В поле Sail Pivot перетащите SailPivot
Шаг 19 Проверка базового движения
1 Нажмите Play
2 Клавиши A и D или стрелки влево и вправо поворачивают лодку
3 Клавиши Q и E поворачивают парус
4 Проверьте, что лодка начинает двигаться вперёд
7 Создание верёвок
Шаг 20 Создание точек крепления
1 Внутри Boat создайте Empty Object MastTop
2 Разместите его в верхней части мачты
3 Внутри Sail создайте Empty Object SailTopLeft
4 Разместите его в верхнем левом углу паруса
5 Внутри Sail создайте Empty Object SailTopRight
6 Разместите его в верхнем правом углу паруса
Шаг 21 Создание объектов верёвок
1 Внутри Boat создайте Empty Object Ropes
2 Внутри Ropes создайте Empty Object RopeLeft
3 Внутри Ropes создайте Empty Object RopeRight
Шаг 22 Создание скрипта RopeVisual.cs
Создайте в папке Scripts скрипт RopeVisual.cs и вставьте код
using UnityEngine;

[RequireComponent(typeof(LineRenderer))]
public class RopeVisual : MonoBehaviour
{
    public Transform startPoint;
    public Transform endPoint;
    private LineRenderer lr;

    void Start()
    {
        lr = GetComponent<LineRenderer>();
        lr.positionCount = 2;
    }

    void Update()
    {
        if (startPoint == null || endPoint == null) return;

        lr.SetPosition(0, startPoint.position);
        lr.SetPosition(1, endPoint.position);
    }
}
Шаг 23 Настройка RopeLeft
1 Выделите RopeLeft
2 Добавьте компонент Line Renderer
3 Добавьте компонент RopeVisual
4 В поле Start Point перетащите MastTop
5 В поле End Point перетащите SailTopLeft
6 В Line Renderer установите Width примерно 0.03
Шаг 24 Настройка RopeRight
1 Выделите RopeRight
2 Добавьте компонент Line Renderer
3 Добавьте компонент RopeVisual
4 В поле Start Point перетащите MastTop
5 В поле End Point перетащите SailTopRight
6 В Line Renderer установите Width примерно 0.03
8 Создание частиц воды
Шаг 25 Создание родительского объекта эффектов
1 Внутри Boat создайте Empty Object
2 Назовите объект Effects
Шаг 26 Создание брызг у носа
1 Внутри Effects создайте Particle System
2 Назовите объект FrontSplash
3 Разместите его спереди лодки
4 Примерно X = 0 Y = 0 Z = 1.5
5 Настройте
6 Start Lifetime = 0.5
7 Start Speed = 1.5
8 Start Size = 0.2
9 Start Color бело-голубой
10 Shape = Cone
Шаг 27 Создание пены за лодкой
1 Внутри Effects создайте Particle System
2 Назовите объект FoamTrail
3 Разместите его сзади лодки
4 Примерно X = 0 Y = 0 Z = -1.5
5 Настройте
6 Start Lifetime = 1.2
7 Start Speed = 0.5
8 Start Size = 0.25
9 Start Color белый
10 Emission Rate over Time = 35
11 Shape = Box
9 Пена в зависимости от скорости
Шаг 28 Создание скрипта FoamBySpeed.cs
Создайте в папке Scripts скрипт FoamBySpeed.cs и вставьте код
using UnityEngine;

public class FoamBySpeed : MonoBehaviour
{
    public Rigidbody boatRb;
    public ParticleSystem foamTrail;
    public float minEmission = 5f;
    public float maxEmission = 60f;
    public float maxSpeed = 20f;

    private ParticleSystem.EmissionModule emissionModule;

    void Start()
    {
        if (foamTrail != null)
        {
            emissionModule = foamTrail.emission;
        }
    }

    void Update()
    {
        if (boatRb == null || foamTrail == null) return;

        float speed = boatRb.velocity.magnitude;
        float emissionRate = Mathf.Lerp(minEmission, maxEmission, speed / maxSpeed);
        emissionModule.rateOverTime = emissionRate;
    }
}
Шаг 29 Подключение скрипта пены
1 Выделите объект FoamTrail
2 Добавьте компонент FoamBySpeed
3 В поле Boat Rb перетащите Rigidbody лодки
4 В поле Foam Trail перетащите FoamTrail
5 Установите
6 Min Emission = 5
7 Max Emission = 60
8 Max Speed = 20
10 Эффект покачивания лодки
Шаг 30 Создание скрипта BoatFloatEffect.cs
Создайте в папке Scripts скрипт BoatFloatEffect.cs и вставьте код
using UnityEngine;

public class BoatFloatEffect : MonoBehaviour
{
    public float floatAmplitude = 0.1f;
    public float floatFrequency = 1f;
    public float tiltAmplitude = 3f;
    public float tiltFrequency = 1.5f;

    private Vector3 startPos;

    void Start()
    {
        startPos = transform.position;
    }

    void Update()
    {
        float yOffset = Mathf.Sin(Time.time * floatFrequency) * floatAmplitude;
        transform.position = new Vector3(transform.position.x, startPos.y + yOffset, transform.position.z);

        float tiltZ = Mathf.Sin(Time.time * tiltFrequency) * tiltAmplitude;
        transform.rotation = Quaternion.Euler(transform.rotation.eulerAngles.x, transform.rotation.eulerAngles.y, tiltZ);
    }
}
Шаг 31 Подключение эффекта покачивания
1 Выделите объект Boat
2 Добавьте компонент BoatFloatEffect
3 Если движение получается слишком сильным уменьшите floatAmplitude и tiltAmplitude
11 Создание зон ветра, тумана и тяжёлой воды
Шаг 32 Создание зоны усиленного ветра
1 В Hierarchy создайте Empty Object
2 Назовите объект WindZone_01
3 Добавьте Box Collider
4 Включите Is Trigger
5 Увеличьте размер коллайдера
Шаг 33 Создание скрипта WindBoostZone.cs
Создайте в папке Scripts скрипт WindBoostZone.cs и вставьте код
using UnityEngine;

public class WindBoostZone : MonoBehaviour
{
    public float boostMultiplier = 2f;

    private void OnTriggerEnter(Collider other)
    {
        BoatController boat = other.GetComponent<BoatController>();
        if (boat != null)
        {
            boat.SetWindBoost(boostMultiplier);
        }
    }

    private void OnTriggerExit(Collider other)
    {
        BoatController boat = other.GetComponent<BoatController>();
        if (boat != null)
        {
            boat.SetWindBoost(1f);
        }
    }
}
Шаг 34 Подключение скрипта к зоне ветра
1 Выделите WindZone_01
2 Добавьте компонент WindBoostZone
3 Установите Boost Multiplier = 2
Шаг 35 Частицы зоны ветра
1 Внутри WindZone_01 создайте Particle System
2 Назовите объект WindParticles
3 Настройте
4 Start Lifetime = 1.5
5 Start Speed = 3
6 Start Size = 0.3
7 Start Color светло-голубой
8 Emission Rate over Time = 25
9 Shape = Box
Шаг 36 Создание зоны тяжёлой воды
1 Создайте Empty Object
2 Назовите объект WaveZone_01
3 Добавьте Box Collider
4 Включите Is Trigger
Шаг 37 Создание скрипта WaterResistanceZone.cs
Создайте в папке Scripts скрипт WaterResistanceZone.cs и вставьте код
using UnityEngine;

public class WaterResistanceZone : MonoBehaviour
{
    public float resistanceMultiplier = 0.5f;

    private void OnTriggerEnter(Collider other)
    {
        BoatController boat = other.GetComponent<BoatController>();
        if (boat != null)
        {
            boat.SetWaterResistance(resistanceMultiplier);
        }
    }

    private void OnTriggerExit(Collider other)
    {
        BoatController boat = other.GetComponent<BoatController>();
        if (boat != null)
        {
            boat.SetWaterResistance(1f);
        }
    }
}
Шаг 38 Подключение скрипта к зоне тяжёлой воды
1 Выделите WaveZone_01
2 Добавьте компонент WaterResistanceZone
3 Установите Resistance Multiplier = 0.5
Шаг 39 Частицы зоны тяжёлой воды
1 Внутри WaveZone_01 создайте Particle System
2 Назовите объект StormParticles
3 Настройте
4 Start Lifetime = 1
5 Start Speed = 2
6 Start Size = 0.5
7 Start Color серо-синий
8 Emission Rate over Time = 20
Шаг 40 Создание туманной зоны
1 Создайте Empty Object
2 Назовите объект MistZone_01
3 Добавьте Box Collider
4 Включите Is Trigger
Шаг 41 Частицы тумана
1 Внутри MistZone_01 создайте Particle System
2 Назовите объект MistParticles
3 Настройте
4 Start Lifetime = 4
5 Start Speed = 0.2
6 Start Size = 2
7 Start Color бело-серый
8 Emission Rate over Time = 10
9 Shape = Box
12 Создание препятствий
Шаг 42 Создание острова
1 Создайте 3D Object → Cylinder
2 Назовите объект Island
3 Увеличьте размеры
4 Добавьте подходящий Collider если это необходимо
5 Создайте тег Obstacle
6 Назначьте этот тег объекту Island
Шаг 43 Создание скалы
1 Создайте 3D Object → Sphere
2 Назовите объект Rock
3 Измените Scale чтобы она выглядела как скала
4 Назначьте тег Obstacle
Шаг 44 Создание префабов
1 Перетащите объекты Island и Rock в папку Prefabs
2 Перетащите WindZone_01 в Prefabs
3 Перетащите WaveZone_01 в Prefabs
4 Перетащите MistZone_01 в Prefabs
5 Перетащите WaterTile_00 в Prefabs и назовите префаб WaterTile
13 Перезапуск игры при столкновении
Шаг 45 Создание скрипта BoatCollision.cs
Создайте в папке Scripts скрипт BoatCollision.cs и вставьте код
using UnityEngine;
using UnityEngine.SceneManagement;

public class BoatCollision : MonoBehaviour
{
    private void OnCollisionEnter(Collision collision)
    {
        if (collision.gameObject.CompareTag("Obstacle"))
        {
            SceneManager.LoadScene(SceneManager.GetActiveScene().name);
        }
    }
}
Шаг 46 Подключение скрипта столкновения
1 Выделите Boat
2 Добавьте компонент BoatCollision
14 Процедурная генерация бесконечного мира
Шаг 47 Создание объекта генератора
1 В Hierarchy создайте Empty Object
2 Назовите объект WorldGenerator
Шаг 48 Создание скрипта InfiniteWorldGenerator.cs
Создайте в папке Scripts скрипт InfiniteWorldGenerator.cs и вставьте код
using System.Collections.Generic;
using UnityEngine;

public class InfiniteWorldGenerator : MonoBehaviour
{
    public Transform player;
    public GameObject waterTilePrefab;
    public List<GameObject> obstaclePrefabs;
    public List<GameObject> zonePrefabs;
    public List<Material> waterMaterials;

    public int tileSize = 50;
    public int visibleTilesAhead = 6;
    public int visibleTilesBehind = 2;

    private Dictionary<int, GameObject> spawnedTiles = new Dictionary<int, GameObject>();

    void Update()
    {
        if (player == null || waterTilePrefab == null) return;

        int playerTileIndex = Mathf.FloorToInt(player.position.z / tileSize);

        for (int i = playerTileIndex - visibleTilesBehind; i <= playerTileIndex + visibleTilesAhead; i++)
        {
            if (!spawnedTiles.ContainsKey(i))
            {
                SpawnTile(i);
            }
        }

        List<int> tilesToRemove = new List<int>();

        foreach (var pair in spawnedTiles)
        {
            if (pair.Key < playerTileIndex - visibleTilesBehind || pair.Key > playerTileIndex + visibleTilesAhead)
            {
                Destroy(pair.Value);
                tilesToRemove.Add(pair.Key);
            }
        }

        foreach (int key in tilesToRemove)
        {
            spawnedTiles.Remove(key);
        }
    }

    void SpawnTile(int index)
    {
        Vector3 position = new Vector3(0f, 0f, index * tileSize);
        GameObject tile = Instantiate(waterTilePrefab, position, Quaternion.identity);
        tile.name = "WaterTile_" + index;
        spawnedTiles.Add(index, tile);

        AssignRandomWaterMaterial(tile);
        SpawnObjectsOnTile(tile.transform, position);
    }

    void AssignRandomWaterMaterial(GameObject tile)
    {
        if (waterMaterials == null || waterMaterials.Count == 0) return;

        Renderer renderer = tile.GetComponent<Renderer>();
        if (renderer != null)
        {
            Material randomMaterial = waterMaterials[Random.Range(0, waterMaterials.Count)];
            renderer.material = randomMaterial;
        }
    }

    void SpawnObjectsOnTile(Transform parent, Vector3 tilePosition)
    {
        if (obstaclePrefabs.Count > 0 && Random.value > 0.4f)
        {
            int count = Random.Range(1, 4);

            for (int i = 0; i < count; i++)
            {
                GameObject prefab = obstaclePrefabs[Random.Range(0, obstaclePrefabs.Count)];
                Vector3 pos = tilePosition + new Vector3(Random.Range(-20f, 20f), 0.5f, Random.Range(-20f, 20f));
                Instantiate(prefab, pos, Quaternion.identity, parent);
            }
        }

        if (zonePrefabs.Count > 0 && Random.value > 0.5f)
        {
            GameObject prefab = zonePrefabs[Random.Range(0, zonePrefabs.Count)];
            Vector3 pos = tilePosition + new Vector3(Random.Range(-15f, 15f), 0f, Random.Range(-15f, 15f));
            Instantiate(prefab, pos, Quaternion.identity, parent);
        }
    }
}
Шаг 49 Подключение генератора
1 Выделите WorldGenerator
2 Добавьте компонент InfiniteWorldGenerator
3 В поле Player перетащите Boat
4 В поле Water Tile Prefab перетащите префаб WaterTile
5 В список Obstacle Prefabs добавьте Island и Rock
6 В список Zone Prefabs добавьте WindZone_01 WaveZone_01 MistZone_01
7 В список Water Materials добавьте M_Water_Calm M_Water_Deep M_Water_Storm M_Water_Shallow
15 Динамическая сила ветра
Шаг 50 Создание скрипта WindManager.cs
Создайте в папке Scripts скрипт WindManager.cs и вставьте код
using UnityEngine;

public class WindManager : MonoBehaviour
{
    public BoatController boat;
    public float minWindStrength = 0.5f;
    public float maxWindStrength = 2f;
    public float changeSpeed = 0.5f;

    void Update()
    {
        if (boat == null) return;

        float wind = Mathf.Lerp(minWindStrength, maxWindStrength,
            (Mathf.Sin(Time.time * changeSpeed) + 1f) / 2f);

        boat.windStrength = wind;
    }
}
Шаг 51 Подключение менеджера ветра
1 В Hierarchy создайте Empty Object
2 Назовите объект WindManager
3 Добавьте компонент WindManager
4 В поле Boat перетащите Boat
5 Установите
6 Min Wind Strength = 0.5
7 Max Wind Strength = 2
8 Change Speed = 0.5
16 Создание облаков
Шаг 52 Создание слоя облаков
1 В Hierarchy создайте 3D Object → Plane
2 Назовите объект CloudLayer
3 Установите Position
4 X = 0
5 Y = 40
6 Z = 0
7 Установите Scale
8 X = 20
9 Y = 1
10 Z = 20
Шаг 53 Создание материала облаков
1 В папке Materials создайте материал M_Clouds
2 Сделайте его светло-серым или назначьте текстуру облаков если она есть
3 Перетащите материал на CloudLayer
Шаг 54 Создание скрипта CloudMover.cs
Создайте в папке Scripts скрипт CloudMover.cs и вставьте код
using UnityEngine;

public class CloudMover : MonoBehaviour
{
    public float speed = 1f;
    public float resetDistance = 200f;
    private Vector3 startPosition;

    void Start()
    {
        startPosition = transform.position;
    }

    void Update()
    {
        transform.position += Vector3.right * speed * Time.deltaTime;

        if (Vector3.Distance(startPosition, transform.position) > resetDistance)
        {
            transform.position = startPosition;
        }
    }
}
Шаг 55 Подключение облаков
1 Выделите CloudLayer
2 Добавьте компонент CloudMover
3 Установите
4 Speed = 1
5 Reset Distance = 200
17 Добавление звука
Шаг 56 Импорт аудиофайлов
1 Перетащите в папку Audio файлы ветра и чаек
Шаг 57 Фоновый звук ветра
1 Создайте Empty Object
2 Назовите объект WindAudio
3 Добавьте компонент Audio Source
4 В поле Audio Clip укажите звук ветра
5 Включите Play On Awake
6 Включите Loop
7 Volume установите около 0.3
8 Spatial Blend = 0
Шаг 58 Звук чаек
1 Создайте Empty Object
2 Назовите объект SeagullAudio
3 Добавьте Audio Source
4 В поле Audio Clip укажите звук чаек
5 Включите Play On Awake
6 Включите Loop
7 Volume установите около 0.2
8 Spatial Blend = 0
18 Интерфейс и счётчики
Шаг 59 Создание Canvas
1 В Hierarchy создайте UI → Canvas
Шаг 60 Создание текста дистанции
1 Внутри Canvas создайте UI → Text
2 Назовите объект DistanceText
3 Укажите начальный текст Дистанция: 0
Шаг 61 Создание текста силы ветра
1 Внутри Canvas создайте UI → Text
2 Назовите объект WindText
3 Укажите начальный текст Сила ветра: 0
Шаг 62 Создание объекта GameManager
1 В Hierarchy создайте Empty Object
2 Назовите объект GameManager
Шаг 63 Создание скрипта DistanceTracker.cs
Создайте в папке Scripts скрипт DistanceTracker.cs и вставьте код
using UnityEngine;
using UnityEngine.UI;

public class DistanceTracker : MonoBehaviour
{
    public Transform player;
    public Text distanceText;

    void Update()
    {
        if (player == null || distanceText == null) return;

        float distance = player.position.z;
        distanceText.text = "Дистанция: " + Mathf.Max(0, distance).ToString("F0") + " м";
    }
}
Шаг 64 Подключение DistanceTracker
1 Выделите GameManager
2 Добавьте компонент DistanceTracker
3 В поле Player перетащите Boat
4 В поле Distance Text перетащите DistanceText
Шаг 65 Создание скрипта WindUI.cs
Создайте в папке Scripts скрипт WindUI.cs и вставьте код
using UnityEngine;
using UnityEngine.UI;

public class WindUI : MonoBehaviour
{
    public BoatController boat;
    public Text windText;

    void Update()
    {
        if (boat == null || windText == null) return;

        windText.text = "Сила ветра: " + boat.windStrength.ToString("F1");
    }
}
Шаг 66 Подключение WindUI
1 На объект GameManager добавьте компонент WindUI
2 В поле Boat перетащите Boat
3 В поле Wind Text перетащите WindText
19 Итоговая проверка сцены
Шаг 67 Проверка объектов в Hierarchy
В сцене должны быть основные объекты
1 Sun
2 Boat
3 BoatFront
4 Mast
5 SailPivot
6 Sail
7 MastTop
8 SailTopLeft
9 SailTopRight
10 Ropes
11 RopeLeft
12 RopeRight
13 Effects
14 FrontSplash
15 FoamTrail
16 WindZone_01
17 WaveZone_01
18 MistZone_01
19 WorldGenerator
20 WindManager
21 CloudLayer
22 WindAudio
23 SeagullAudio
24 Canvas
25 DistanceText
26 WindText
27 GameManager
Шаг 68 Проверка управления
1 Нажмите Play
2 Проверьте поворот лодки клавишами A и D
3 Проверьте поворот паруса клавишами Q и E
4 Убедитесь, что лодка движется вперёд
Шаг 69 Проверка эффектов
1 Проверьте покачивание лодки
2 Проверьте пену за лодкой
3 Проверьте брызги у носа
4 Проверьте частицы ветра
5 Проверьте частицы тумана
6 Проверьте облака
7 Проверьте звуки
Шаг 70 Проверка бесконечного мира
1 Двигайтесь вперёд по оси Z
2 Убедитесь, что впереди появляются новые водные тайлы
3 Убедитесь, что старые тайлы удаляются
4 Убедитесь, что на новых тайлах появляются препятствия и зоны
Шаг 71 Проверка столкновения
1 Направьте лодку в остров или скалу
2 Убедитесь, что сцена перезапускается
Шаг 72 Проверка интерфейса
1 Убедитесь, что дистанция увеличивается во время движения
2 Убедитесь, что сила ветра отображается на экране
20 Что нужно сдать
Итог работы
1 Unity проект
2 Сцену OceanScene
3 Все скрипты проекта
4 Работающий игровой прототип
5 Краткий отчёт
Что написать в отчёте
1 Тема работы
2 Цель работы
3 Какие физические эффекты были реализованы
4 Как работает движение лодки
5 Как работает парус
6 Как реализованы зоны ветра и тяжёлой воды
7 Как работает генерация бесконечного мира
8 Какие трудности возникли
9 Вывод по работе
21 Список всех скриптов проекта
1 SailClothEffect.cs
2 BoatController.cs
3 RopeVisual.cs
4 FoamBySpeed.cs
5 BoatFloatEffect.cs
6 WindBoostZone.cs
7 WaterResistanceZone.cs
8 BoatCollision.cs
9 InfiniteWorldGenerator.cs
10 WindManager.cs
11 CloudMover.cs
12 DistanceTracker.cs
13 WindUI.cs
22 Контрольный результат
Если всё сделано правильно, у вас должен работать следующий игровой цикл
1 игрок управляет лодкой
2 поворачивает парус
3 лодка движется за счёт ветра
4 пена и брызги показывают движение по воде
5 в мире встречаются зоны усиленного ветра и тяжёлой воды
6 генерируются новые участки океана
7 появляются острова и скалы
8 облака движутся
9 звук ветра сопровождает игру
10 на экране отображаются дистанция и сила ветра
23 Вывод
В ходе практической работы вы создаёте не отдельный эффект, а полноценный игровой прототип, в котором объединяются ткань, верёвка, частицы, вода, воздух, туман и процедурная генерация мира. Эта работа показывает, как разные физические эффекты используются в одном проекте и влияют на игровой процесс

